Sprememba mape za Synology media server

Ko vklopite Synology Media Server na svojem NAS strežniku, vam ta kreira 3 nove mape (“video”, “music” in “photo”) in omogoči, da jih lahko uporabite preko storitev DLNA/UPnP. Morda vam ne bo odgovarjalo mesto, kamor bo Media Server te mape postavil, in bi raje videli, da se mape nahajajo na kakšnem drugem disku.

Kar potrebujete, je ssh dostop do Synology NAS strežnika. Nato pa vpišete ukaz:

mount --bind /volume2/MyMusicDirectory /volume1/music

Pozor! Ko boste to naredili, vam bodo izginile vse datoteke, ki jih je ustvaril Media Server in ki ste jih imeli v direktorijih.

Da pa bo zadeva delovala tudi po ponovnem zagonu NAS strežnika, je treba ukaz zapisati še v /etc/rc.local datoteko. Torej naredimo naslednje:

vi /etc/rc.local

Zadeva bi sedaj morala delovati 🙂

RouterOS – blokiranje portov, ki jih uporabljajo virusi

Na Mikrotiku zelo enostavno zapremo porte, ki jih uporabljajo najpogostejši virusi. Vse, kar moramo narediti, je, da v terminalno okno pod /ip firewall filter vpišemo naslednje vrstice:

add chain=virus protocol=tcp dst-port=135-139 action=drop comment="Drop Blaster Worm"
add chain=virus protocol=udp dst-port=135-139 action=drop comment="Drop Messenger Worm"
add chain=virus protocol=tcp dst-port=445 action=drop comment="Drop Blaster Worm"
add chain=virus protocol=udp dst-port=445 action=drop comment="Drop Blaster Worm"
add chain=virus protocol=tcp dst-port=593 action=drop comment="________"
add chain=virus protocol=tcp dst-port=1024-1030 action=drop comment="________"
add chain=virus protocol=tcp dst-port=1080 action=drop comment="Drop MyDoom"
add chain=virus protocol=tcp dst-port=1214 action=drop comment="________"
add chain=virus protocol=tcp dst-port=1363 action=drop comment="ndm requester"
add chain=virus protocol=tcp dst-port=1364 action=drop comment="ndm server"
add chain=virus protocol=tcp dst-port=1368 action=drop comment="screen cast"
add chain=virus protocol=tcp dst-port=1373 action=drop comment="hromgrafx"
add chain=virus protocol=tcp dst-port=1377 action=drop comment="cichlid"
add chain=virus protocol=tcp dst-port=1433-1434 action=drop comment="Worm"
add chain=virus protocol=tcp dst-port=2745 action=drop comment="Bagle Virus"
add chain=virus protocol=tcp dst-port=2283 action=drop comment="Drop Dumaru.Y"
add chain=virus protocol=tcp dst-port=2535 action=drop comment="Drop Beagle"
add chain=virus protocol=tcp dst-port=2745 action=drop comment="Drop Beagle.C-K"
#Skip one line below if you have Squid Transparency Service
add chain=virus protocol=tcp dst-port=3127-3128 action=drop comment="Drop MyDoom"
add chain=virus protocol=tcp dst-port=3410 action=drop comment="Drop Backdoor OptixPro"
add chain=virus protocol=tcp dst-port=4444 action=drop comment="Worm"
add chain=virus protocol=udp dst-port=4444 action=drop comment="Worm"
add chain=virus protocol=tcp dst-port=5554 action=drop comment="Drop Sasser"
add chain=virus protocol=tcp dst-port=8866 action=drop comment="Drop Beagle.B"
add chain=virus protocol=tcp dst-port=9898 action=drop comment="Drop Dabber.A-B"
add chain=virus protocol=tcp dst-port=10000 action=drop comment="Drop Dumaru.Y"
add chain=virus protocol=tcp dst-port=10080 action=drop comment="Drop MyDoom.B"
add chain=virus protocol=tcp dst-port=12345 action=drop comment="Drop NetBus"
add chain=virus protocol=tcp dst-port=17300 action=drop comment="Drop Kuang2"
add chain=virus protocol=tcp dst-port=27374 action=drop comment="Drop SubSeven"
add chain=virus protocol=tcp dst-port=65506 action=drop comment="Drop PhatBot, Agobot, Gaobot"
add chain=forward action=jump jump-target=virus comment="jump to the virus chain"